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Appendix A. Capture Workflow

A.1 Equipment used

A. 2 Set up steps:

1.	 Clean the camera lens using a lens cleaning kit, or lens wipes, to remove any dust or 
smudges.

2.	 Place the camera 0.45m from the area of capture, measuring from the focal plane mark  
using the distometer, focus the image and then tape the focus ring down. 

3.	 Place a long strip of painter’s tape on the floor parallel to the wall directly under the feet of 
the tripod that are closest to the wall. This will aid in correctly placing the camera the correct 
distance from the wall as it moves laterally during capture.

4.	 Place the LEDs behind with even spacing behind painter’s tape, ensuring enough space for 
the camera to laterally move. Plug them in with AC adapters. 

5.	 Set the LEDs to their highest brightness settings for ease of repeatability.
6.	 Adjust the height and angle of the LEDs to avoid casting shadows on the subject wall with 

the camera and tripod. 
7.	 Note the lights’ location, height, and angle for future capture (taking images of the set-up 

helps with this).  
8.	 Ensure that camera settings are correct:
	 a.   Aperture set to f/8
	 b.   Ensure that mirror lock up enabled
	 c.   Exposure delay set to 3sec
	 d.   ISO set to 100
	 e.   Focus set to manual
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	 f.    Turn AF off on the camera
	 g.   Set shutter speed to an acceptable exposure based on lighting conditions. 			
       Note this shutter speed for future epochs.
	 h.   Set image name related to the capture epoch (eg. HD1, for Hardham epoch.
9.	 Position the photogrammetric scale bars with the selfie stick so that they bookend the 

area of capture (40cm x 20cm area). Be sure to position the bars flush to the wall before 
extending them fully, to avoid any risk of mechanical contact with the paintings.

10.	  Place the camera for the first shot, where 1/3 of the image is to the left of the left edge of 
the left-most scale bar, then raise the camera with 1/3 of the image area above the subject. 
Ensure that the tripod can still be raised some from this point. 

11.	 Mark the painter’s tape with 6 lines at 8.5cm intervals on the tape from one of the legs at 
their starting point. This will act as a guide to move the camera to ensure 2/3 lateral overlap 
of the images

12.	 Check the focus of each image prior to capture, moving the tripod slightly forward and 
backward to improve the focus rather than touch the taped focus ring. 

A.3 Capture 

1.	 With the camera level/parallel to the surface, capture six images across, in four rows 
down, ensuring 2/3 vertical overlap (resulting in 24 images).
 

2.	 Then, capture the convergent images: capture six images across in three rows with the 
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camera angled 5 degrees down (ensuring 2/3 vertical overlap), then repeat for 5 
degrees angled up (resulting in 36 additional images).

The Nikon D800 allows the user to precisely tilt the camera 5 degrees using this in-
camera feature. Each horizontal line represents a 5 degrees tilt.
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3.	 Capture eight images across with the camera turned 90 degrees, ensuring that the whole 
area of interest and as much of the scale bars as possible are visible in the image (additional 8 
images)

 

This capture workflow should result in 68 images. Check the images to be sure that they are all in 
focus before uploading them. 

Before removing the tape from the focal ring, follow the Metashape lens calibration steps (see 
Metashape Manual) to capture images of the calibration checkerboard at the same settings used 
on-site.
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Appendix B.  Agisoft Metashape Workflow

B.1 Loading Data

Upon opening Metashape, go to Workflow > Add Photos. From here, select all of the TIFF files 
from the first epoch, and click Open to add them to your first Chunk. Then, click on the chunk, 
normally called ‘Chunk 1’, and repeat the same process for the second epoch. 

Before aligning the images, add the lens calibration file by going to Tools > Camera Calibra-
tion… Then find the ‘load’ icon, to load the calibration file. 

Once the calibration file is loaded, the distortion parameters will be loaded, and the Type will be 
changed to ‘Precalibrated’. 
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With the calibration file loaded, select the chunk and go to Workflow > Align Photos…

Use the High accuracy setting, leaving the key point limit and tie point limit settings1 and select 
‘Adaptive camera model fitting’.2 The High accuracy setting for alignment uses the images at 
their original size, meaning their full resolution. Each step down from the High setting reduces 
the image size by a factor of 4, and using the Highest accuracy setting upscales the image size 
by a factor of 4 and should only be used in discreet research circumstances (Metashape 2018, 
20). 

B.2 Scaling

Once all of the points are aligned, the point cloud can be optimized. First, go to Tools>Mark-
ers>Detect Markers… This will bring up a menu to find the scale targets. Select the Marker 
type used. In this research, the Marker type is Circular 12 bit. Some trial and error is required 
to identify the correct Tolerance setting. For the scale bars used in this research, the optimum 
setting was 50. The lower the Tolerance setting, the stricter the software’s criteria are to identify 
targets. Too high a number can result in erroneous Markers identified, too low a number can 
result in too few or no markers identified. The other selections were not relevant in this research. 

Once the Markers have been identified, at the bottom left of the screen, select the Reference 
tab. In the center of the Reference window, you should see your Markers listed as differently 
numbered targets. In this research, 5 different targets were used, numbered 1-5. Go through the 

1  These settings are typically sufficient to provide enough points without creating too many erroneous points 
(Agisoft Forum 2015).
2  This setting uses reliability estimates to determine which parameters are included in alignment (Metashape 2018, 
21). It was found to generally improves the accuracy of the results in these trials. 
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images and check that the targets have been correctly identified. Once this is done, select two 
targets that are a known distance from each other by clicking each while holding Ctrl. Right click 
and select Create Scale Bar.
 

This will add a scale bar in the bottom section. By double clicking next to the scale bar name, 
under Distance (m), the distance between scale bars in metres can be manually input. In these 
trials, this distance was 0.10m. Repeat this process for each scale bar available, ensuring that the 
correct target numbers are being selected. 
 
B.3 Optimization

Once the point cloud has been scaled, click the ‘Optimize Cameras’ icon on the reference tab, 
shaped like a star and optimise the cameras with adaptive camera fitting checked. 



WENDY ROSE • CONSERVATION OF WALL PAINTING DEPARTMENT • COURTAULD INSTITUTE OF ART

118

An investigation into the viability of photogrammetry as a practical tool for in-situ 3D condition monitoring

Once the cameras have been optimised, go through the following ‘Gradual Selection’ procedure, 
optimising the cameras after each set of parameters is adjusted:

Model > Gradual Selection…
Criterion: Reprojection Error - set to 0.2
Delete the selected points
-Optimize Cameras-

Model > Gradual Selection…
Criterion: Reconstruction Uncertainty - set to 25
Delete the selected points
-Optimize Cameras-

Model > Gradual Selection…
Criterion: Projection Accuracy - set to 10
Delete the selected points
-Optimize Cameras-

Check to make sure that the RMS error is below 0.5 pixel by right clicking on the Chunk > Show 
Info…

B.4 Separating the point clouds

Select the chunk with both sets of images, right click and select ‘Duplicate…”. Rename each 
Chunk to represent one epoch and delete the images from each respective chunk so each chunk 
contains only a single epoch.  

Build each dense cloud by going to Workflow > Dense cloud…

Create the cloud on Quality – High, with a depth filtering – Mild. 

The quality settings for the dense cloud generation are similar to the sparse cloud, with Ultra 
High quality upscaling images provided, and the High quality setting using the full resolution of 
the images, with each step down reducing the size of the images by a factor of 4. 

An aggressive depth filtering, which is typically the standard setting, enables the programme to 
filter out ‘outlier’ points that may be generated from badly focused or noisy images. However, 
this can result in a loss of small geometric details that the programme may misinterpret as noise 
(Metashape 2018, 23). Given that these trials aim to detect small 3D changes, it was determined 
that depth filtering should be set to Mild to try to maintain as much detail as possible. 
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B.5 Exporting the point clouds

Once the dense clouds are generated, it is important to check them for holes in the point cloud. 
The easiest way to do this is to click down on the dense cloud icon menu and select Dense Cloud 
Classes. This shows the point cloud without colour data and makes it easier to locate holes or 
problematic areas in the model. If holes are present it is important to note this so that they are not 
misinterpreted as change in the comparison. 

Right click on each Chunk and select Export > Export Points… Select an area to save the clouds 
in and create a filename that will accurately communicate the epoch that the point cloud is from 
and the partner point cloud that the cloud was built with, eg. ‘HD1 with HD2’. Make sure that the 
cloud is exported as Standford PLY (*.ply) in the ‘Save as type’ menu. This will then open a menu 
where you can change the settings of the point cloud. All of the standard settings can be used for 
these trials.



120
WENDY ROSE • CONSERVATION OF WALL PAINTING DEPARTMENT • COURTAULD INSTITUTE OF ART • 2019

An investigation into the use of photogrammetry as a tool for in-situ 3D monitoring of wall paintings

Appendix C. CloudCompare Workflow

C.1 Loading data

Upon opening CloudCompare, go to File > Open and select the two point cloud (.ply) files that 
you want to compare. A menu will come up asking for all of the features of the .ply file to be 
applied. Click Apply all’.

C.2 Cropping the point clouds

Once both point clouds are loaded in, select both clouds (holding down Ctrl) and then click the 
‘Segment’ icon from the top tool bar, which looks like a pair of scissors. 
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This feature will allow you to crop both of the point clouds simultaneously. In order to crop 
them as a rectangle, go to the small empty polygon shape in the new tool bar in the upper right 
corner and select ‘Rectangular selection’ in the drop-down menu, then select the area that you 
want to compare. 

Once the desired area is selected, click the filled in red polygon icon to ‘Segment In’. Then, 
when the area is cropped, click the green check mark to ‘Confirm Segmentation’. 

C.3 Compute cloud to cloud distance

This will result in two clouds for each epoch, one with the desired cropped area, and one with 
the discarded area. Select each cloud containing the desired cropped area (hold Ctrl), usually 
named ‘Cloud.segmented’, and then click on the ‘Compute cloud/cloud distance’ icon on 
the top tool bar.  Be sure that your first epoch is the ‘Reference’ cloud. Click swap if it is not. 
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The ‘Distance computation’ menu will appear and there is a choice to make:
1.	 Rely on the CloudCompare software to determine the Octree level (leave it set to AUTO)

OR
2.	 Select the max. distance that the software can detect: this is often helpful after a first run-

through on AUTO, as it allows the user to define the Scalar field range and pushes the 
software to high Octree levels. 

Check the box to ‘split X,Y, and Z components’ to ensure that the direction of change can be 
interrogated.  And then click ‘Compute’.

Once the distance is calculated, select the cloud that has the scalar field (the Compared cloud),  
and go into the Properties box at the bottom, checking ‘Visible’ under the Colour Scale tab in 
order to view the Scale bar. 

C.4 Exporting the histogram data and saving the comparison

In order to export the histogram data, click on the to the 'Histogram' icon  on the top 
toolbar, expand the window and click either the '.csv' icon to export as a .csv file, or the 'export to 
an image file' icon to export an image of the histogram. 

To save the comparison, select each point cloud that you want to save by holding down Ctrl, then 
go to File>Save to save it as a CloudCompare readable '.bin' file.


